Sublime3 安装SublimeLinter PHP+Javascipt+CSS 帮助检测语法错误

前段时间把自己的Sublime2更新到了3,发现原先的SublimeLinter配置文件不起作用了。目前国内给出相应答案的网站比较少,现在给出对于Sublime3的解决方案。

在Sublime3中,SublimeLinter的检测插件被独立了出来,也就是说我们除了SublimeLinter本体以外,我们还需要安装Sublimelinter-phpSublimelinter-jshintSublimelinter-csslint这三个插件。

QQ截图20150918184608

然后需要用nodejs安装jshint和csslint,使用如下命令。(没有安装nodejs请先安装nodejs)

安装完成后如下图所示

QQ截图20150918182832

可以使用如下命令检查这两个插件是否安装完成

除了nodejs以外,我们还需要php程序包,没有的可以到http://php.net/downloads.php这里下载,这里我放到了D盘根目录

QQ截图20150918185414

接下来打开SublimeLinter的设置,如下图

QQ截图20150918184709

我们配置文件修改如下

其中paths项,需要把PHP的路径放进去,show_errors_on_save可以控制是否在保存的时候提示错误,这里我选择了打开

然后重启sublime,就可以执行代码检查了

发表评论

电子邮件地址不会被公开。 必填项已用*标注